The DreamerThe Beastie Blog

patches
I'm a (bad) C Programmer, so I broke net/tigervnc
18 Dec 2014 Back on November 19th, x11/gnome2 and pretty much everything associated with it disappeared from ports and x11/gnome3 appeared. I had just switched ‘zen’ over to getting pkg upgrades via my private package repository courtesy of ports-mgmt/poudriere the day before. I have a mostly working, every so often it misses a day…usually when I’ve been messing around with extra bulk jobs the night before….a CFEngine driven daily mash up of ports and (my) patches, using ports-mgmt/portshaker (originally installed before linux-c6 was finally able to replace linux-f10….) and then running two bulk jobs, one after the other.
patches
Was too late getting in my patch for multimedia/thumbnailer
8 Dec 2014 Back on December 1st, this updated port failed to build for me. After a quick head scratch, I figured out the next daynight that adding compiler:c++11-lang to USES would make it build.
patches
configure error trying to build thunderbird-31.3.0
5 Dec 2014 Couple days ago an update to mail/thunderbird appeared, and it was failing during configure. Results in poudriere skipping some 20+ ports. Which is strange since mail/thunderbird is a leaf port. And, I only just got x11/gnome3 done in poudriere, on the fence on whether I’d through in the perl update now or later. The finally stopper is editors/libreoffice which takes too long to build, and get’s killed just before my daily refresh of my ports directories.
patches
updated deskutils/gcalcli to use Google's V3 Calendar API
3 Dec 2014 On November 17th, Google pulled the plug on its deprecated V2 Calendar API. Found that gcalcli had apparently undergone a complete(?) rewrite to support V3 differently, but no release had been made/tagged. So, I devised a quick and dirty patch to grab its state on 20141031. So, created a PORTVERSION of either 3.1.a.20141031 or 3.0.a.20141031. Not really clear if the first came before 3.1, so opted to err on the cautious side, figuring I’d get corrected after I submitted….
patches
patch audio/espeak for Gnome3's pulseaudio
21 Nov 2014 As part of the sudden loss of Gnome2 and the appearance of Gnome3, audio/pulseaudio got a significant bump in version (0.9.23 -> 5.0) This resulted in (re)build failure for audio/espeak if something other than the default option of PORTAUDIO is selected. RUNTIME includes both audio/portaudio and audio/pulseaudio as LIB_DEPENDS.
patches
patch archivers/ruby-lha for ruby 2.0
21 Nov 2014 In UPDATING on 20141008, the default ruby version was updated from 1.9 to 2.0. Long ago, in addition to listing where my “default versions” differed from default (ie mysql=55p instead of mysql=55), I had added in definitions for all of the then default versions to DEFAULT_VERSIONS= in my make.conf file. Partly to avoid surprise changes, or from forgetting to check UPDATING until after I had started updating my ports. With the added benefit that if I’m not ready to make the switch, I don’t have to right away. Additionally, now that I’m doing unattended daily poudriere builds, it avoids surprises to my package repo (to some extent….)
patches
updating x11/nvidia-driver-304 to 304.123 with poudriere testport
6 Nov 2014 This work in progress first started on September 18th, 2014, suffered a setback when a portsnap clobbered my work in progress under /usr/ports around September 29th, 2014 (Mondays… :gimacing:) And, then got set aside as felt the need for a proper rework of master port before submitting a PR.
other
ZFS and tuning Postgresql
14 Sep 2014 For the umpteenth time, I found myself looking over mysql parameters, reading documentation and fiddling with more settings. Whereas my PostgreSQL setup, I have done very little in the way of fiddling with its configuration. Not sure if that says anything about one versus the other.
patches
Cannot determine local time zone
22 Aug 2014 Some time after DateTime::TimeZone 1.71, my irssi restarted. And, some time after that, I noticed that twirssi wasn’t running for some reason. When I tried to get twirssi to load, it reported an error of “Cannot determine local time zone”. I eventually found that this is this is from a call to die in DateTime::TimeZone::Local, and that through a variety of troubleshooting measures that it only happened inside of irssi and that rolling back to DateTime::TimeZone 1.69 got things working again.
patches
Getting closer to pushing FreeBSD process priorites up into CFEngine
9 Aug 2014 In auto-nice daemon vs. CFEngine, I made had made a patch to sysutils/cfengine35 to enable finer grain process priority control on my FreeBSD servers. Today, I decided that I should see about getting it into the upstream, since 3.6 had already been released and more recently 3.6.1 has appeared. Given the major problems I had when I accidentally upgraded myself from 3.4.4 to 3.5.0, because I had been using sysutils/cfengine… I had decided a while back to switch to using sysutils/cfengine35 so that I can make the leap to 3.6 on my own timeline (which could be never, though probably not since there’s some interesting new things in it that I will want to try eventually :pensive:) Though I still have a lot of other things I want/need to do before I get there.
other
math/orpie: update to 1.5.2
4 Aug 2014 Back on May 26, 2014, I wrote about having updated math/orpie to 1.5.2, which ended with me wondering when I would get around to submitting it?
other
ports-mgmt/pkg (1.3.4) quiet delete doesn't
3 Aug 2014 Decided that it was time to cleanup the pkg’s installed on my system. Since the other day I watched it take forever to update a port, that turned out to be a leaf package. Leftover dependency from something I choose not to keep around. There are also other big left over build dependencies that for whatever reason weren’t marked as automatic or removed automaticallly at the end of a portmaster (w/ –delete-build-only) run.
patches
irc/bitlbee update forces me to update irc/irssi-otr port
21 Jul 2014 The recent update to the irc/bitlbee port ran into a snag for me. The update changes its dependency on security/libotr3 to security/libotr (4.0.0), where the two ports conflict with each other but irc/irssi-otr still depends on the older library. This makes it hard to use OTR when both bitlbee and irssi are on the same server, which is how I use it.
other
Toggling the base colors of my theme
20 Jul 2014 Following the work I did on 'GitHub Pages Plugin to linkify references to ports?', the urge to fiddle with more javascript and css struck. The color scheme of this site is based on Solarized: Precision colors for machine and people, where I had originally created this site based on having a light background.
other
GitHub Pages Plugin to linkify references to ports?
20 Jul 2014 Following my previous post, GitHub Pages Plugin to linkify PR: references?, on June 8th, I updated the URL generated to point to the new bugzilla site. I then made a mod on June 14th to handle PR: lines with just numbers following it. Though I didn’t get that mod working until June 26th when I created a post using the syntax.
patches
patching audio/gsm
19 Jul 2014 Got a strange error, while troubleshooint something else likely unrelated, about /usr/local/bin/tcat and /usr/local/bin/untoast. Examining the files, I found: ...
ports
[new port] www/p5-LWP-Protocol-connect: provides HTTP/CONNECT to LWP::UserAgent
10 Jul 2014 Seems to me that proxy support for connecting to https sites with LWP::UserAgent had been broken forever. But, then I get asked to install a commericial product's perl script into one of our nagios instances, and its relying on LWP::UserAgent's proxy method to work correctly when POST'ng to its https site. Or, it still thinks people only run such sites were direct access to the Internet is always possible.
other
sysutils/nut is causing my system to panic during boot
9 Jul 2014 Being crazy, I decided to run freebsd-update install from work on my home computer, to take it up to 9.2-FreeBSD-p10. I rebooted and it never came back.
other
removal of USE_AUTOTOOLS broke build of security/openconnect
7 Jul 2014 This morning ran into an update to security/openconnect removed USE_AUTOTOOLS, which broke the build for me.
patches
Fix build of devel/libexecinfo on amd64
28 Jun 2014 So, I have not had a working chromium on FreeBSD since 33.0.1750.152_1. And, this has been really annoying. I had even tried recompling everything it depended on, which only made the problem worse. Though that was partly because I had made the mistake of turning on the DEBUG option. All the while, everything continued to point to libexecinfo as the problem dependency. But, all the rebuild/reinstalls of it didn’t make any difference.
Older entries Newer entries